Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Common issues after upgrading from 3.2.1.4 to 4.3.4

6 years 2 months ago
Licenses:

HI, Manos.

I do not have access to This email address is being protected from spambots. You need JavaScript enabled to view it.. Please, send me them at This email address is being protected from spambots. You need JavaScript enabled to view it..


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
6 years 2 months ago
Licenses:
JomSocial Active

I have forwarded them now.

All those issues have been delayed for many days, because your system with adding passwords in the hidden box does not work and cuts the passwords. So fix that as well.

Also, I can't even send you PM with the passwords. At least put your email in your profile so that we know.

Please proceed with fixing the forum avatars and include this in the next version. We have no forum avatars for 3-4 days, we have 43.000 registered users (a couple of hundreads active with daily posts) and many of them complain in all social media!

6 years 2 months ago
Licenses:

HI, Manos.

I repeat for the 3rd time - Kunena avatar issue is NOT related with JomSocial but rather with Kunena settings. After taking a peek into your site it appears that you just don't have Kunena - JomSocial plugin installed (this one: prntscr.com/hjqywi ) It comes with Kunena package and is maintained by Kunena Team). You could have that fixed right after you reported this by just installing and enabling this plugin... please, pay more attention to what I wrote :)

I also compared passwords you've sent via email and the one you saved on forum - they are exactly the same and nothing was cut out. Now the password from forum works - but It didn't when I checked it last time.

Search page issue is cause due:
<b>Fatal error</b>: Call to undefined function iconv() in <b>/home/gameworl/public_html/components/com_community/helpers/string.php</b> on line <b>316</b><br />
prntscr.com/hjr4bw

Solution: www.jomsocial.com/forum/profile-universa...n-iconv-error#173871

I'm not sure what you mean by this:

Also I need to disable the whole in-JomSocial Search function with Autocomplete, which currently exists on the right to "New messages" in my profile. How can I do that?

Could you add the print screen and mark what element do you mean?

On the left at Community frontpage you have modules with new profiles, photos and videos. Just disable those modules in Joomla!.

Messages do not display titles as they just notice who recently send you a message on chat. Private Messages ware replaced by chat - chats do not have subjects/titles :)

You may build your search query with advanced search - just select what field you want to search in. You need to enable/install iconv() library on your server to fix advanced search.

No one her says it's JomSocial fault: www.kunena.org/forum/general-questions-a...nd-avatars-are-blank

Goran just says that you should upgrade JS to most recent version 4.5 as you use outdated version. Goran is also not part of Kunena Team... so they didn't even answered you :) I already explained what cause that issue.

Run cron job to check if this clear the list. Also of they are doubled in content?

Login screen is part of your template - not JomSocial. I don't know what you had there and why it's gone. maybe you sued module there and it's not enabled?


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
The following user(s) said Thank You: Goran
6 years 2 months ago
Licenses:
JomSocial Active

First of all reply only in numbers. Iam not supposed to play hide and seek with all the issues.

1)Where is the JomSocial - Kunena plugin? I've searched in both your site and Kunena site and I didn't find anything. Why don't you make it simple? Put a "Downloads" link everyone and "Main component | Plugins | Languages" etc. menus inside there so that everyone can understand everything. Send me a link. Iam so confused that I have asked both Kunena and you because I haven't figured out yet who made the Plugin.

2)The search function doesn't work now. - www.gameworld.gr/community/advancedsearch
Your solution link is "You need install iconv() library on your PHP server, please contact your sys-admin to enable it.. i wouldnt so hard to enable it ;)"

I don't have a sysadmin and I don't have the budget. Please enable it, you have all the passwords in your email.

3)I want to disable this Search function in Site.com/Profile which is right next to the "PM" icon, just to see if I will save some extra speed. Very few people will use this search.

4)In www.Gameworld.gr/Community , tell me the exact name of the modules that I need to deactivate. I don't want to see new profiles, new photos and new videos. I want that page to be exactly like it was before. How can I disable those three? I type "JomSocial" in Module Manager and Plugins and I can't find anything. If you are not specific then you are not helping.

5)I don't want any chat in my site! I want the Private Messages to be like they were used to be. For what reason did you do this? It's a Private Message! You have to click on that private message and before clicking there is a PREVIEW of the text you are reading! ALL social networks in the world have preview of the private message! JomSocial did this too. Who decided this? I use Internet since 1997 and Iam an admin since then. There is no social media system in the world which has this thing. We need a hotfix for preview and an option in Settings to re-enable it. I have 45.000 users and whoever I ask for this, he complains. Iam already losing users for many issues and this is just one of them.

6)Ok I will ask my developer to upgrade to JomSocial v4.5
www.kunena.org/forum/general-questions-a...nd-avatars-are-blank

7) After you make the search work ( www.gameworld.gr/community/advancedsearch ) I need to search both by username and full name. Ex. when you type Manos + Search by Username, you need to see usernames that have "Manos" in them. If you type Christiana + Search by Username, you will see usernames with Christiana.
If you type "Μάνος Γρυπάρης" + Search by Full Name
or "Γιάννης Μοσχονάς" + Search by Full Name
..then you should see just one username. This is for testing purposes.

8)About the empty login window on the right, before JomSocial upgrade it used to work normally and now it doesn't. Which folders and files does JomSocial affect in terms of login window which shows private messages, notifications. etc? I need to know because this is custom work.

9)Finally what can you say about the site going x3 times slower? I open Gameworld.gr/Community and GameWorld.gr/Community/Profile . Everything is running DEADLY slow! Before upgrading I used to have a speed of 3 seconds and now it takes more than 10 seconds! People are already leaving my site for this.

6 years 2 months ago
Licenses:

Hi, Manos.

1. I already explained: "It comes with Kunena package and is maintained by Kunena Team". It's INSIDE Kunena installation package. I can't send you link as it's INSIDE Kunena zip. After you install Kunena, plugin is also installed... it seems that you removed it.

2. I'm sorry but we do not support problematic hosting. We've made that clear in our Support Policy: www.jomsocial.com/support-policy
Issue is caused by your server incapability to support JomSocial. You'll need to solve this issue on your side. I just explained what needs to be done.

3. Do you mean this: prntscr.com/hjzrv1 ?
If yes, just add this code:

.joms-js--notification-search {display: none !important;}

Add it to ROOT/templates/cepon/css/custom.css

4. prntscr.com/hjzt5r this are module TITLES, you'll find them at Backend -> Extensions -> Modules. Just disable them and they will be gone.

5. No, sorry, this is one way ticket, this can't be undo. This way of development was decided by Project Manager. If you want to talk about it, please, contact Sinisa. This feature wile be improved in next versions.

7. I already explained: "You may build your search query with advanced search - just select what field you want to search in. You need to enable/install iconv() library on your server to fix advanced search." Take a look here and click "Add criteria": www.jomsocial.com/community/search/advancesearch

8. JomSocial updated files that belong to the package. It do not touch any of your customizations. If you had there a custom module - then it needs to be upgraded to follow JomSocial. I'm sorry but we do not support any customizations. If they do not work - you need to contact your developer who made this for you. Everything is moving forward and things just get old. You can't expect that something that was working with old version will work the same way with new one. Soon Joomla! will move to 4, then you'll understand what I mean :)

9. I would say that for me your site loads quite fast. The same says Pingdom Tools: prntscr.com/hjzzmy
What browser do you use? If Chrome 62 then there is known bug in this browser, that make site with JomSocial very slow. Bug is fixed in Chrome 64.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
6 years 2 months ago
Licenses:
JomSocial Active

2)The search function doesn't work now. - www.gameworld.gr/community/advancedsearch
Your solution link is "You need install iconv() library on your PHP server, please contact your sys-admin to enable it.. i wouldnt so hard to enable it ;)"

"Issue is caused by your server incapability to support JomSocial. You'll need to solve this issue on your side. I just explained what needs to be done."

Give me detailed instructions on how to install icov() library. I have a web developer. We are NOT sysadmins here and I can't find a proper sysadmin! This is why we ask support and this is why we give you our admin account and password. If you are not willing to help then why do we give you our account and password anyway? Or if you want to help then tell me exactly how to install this icov() library with detailed instructions like SSH commands etc.

3)Add the code WHERE exactly? Why do you give half responses and never speak specifically here?

5)Make sure that it's done as quickly as possible. Really ,when you change something, first ask! Or give an other option in settings.
About the names appearing 2 times, what should I do?

The rest will be replied once I have news for everything.

6 years 2 months ago
Licenses:

Hi, Manos.

2. I repeat, we do not provide support for server issues. The purpose of our Technical Support is to cover issues with JomSocial. This is issue with your server - not JomSocial. I can't provide you details how to administer your server as this is out of scope of our support. So it's not that I don't want to help, just our support work to some extent.

3. Manos, please, read my answer carefully: prntscr.com/hk6wtj My answer contain where to add the code.

5. But what you expect to be done? You mean you want use to ask users each time we plan to change something or add new feature? :) LOL, c'mon, let's be serious :) As for the names, do same thing - messages - are displayed when you click on duplicated names? May I see this issue somehow?


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
6 years 2 months ago
Licenses:
JomSocial Active

2)Ok I have solved the issue with Search function by installing the iconv library.

Also, I want to search by both Name or Username. I want both fields in the search function. Is there an option to enable Username? We had a username search in the old version but it was never working and you had promised that it will be fixed within months.





10)In my profile why do those empty box messages appear?

www.Gameworld.gr/Community/Manos

Attachments:
6 years 2 months ago
Licenses:

HI, Manos.

2. In JomSocial you may choose to display username (login) or real name (name).
prntscr.com/hkcyyx
Search option could search only what is visible at the moment. Field "Name" in search criteria will allow you to search currently set name - username or real name. But you can't search by value that is not visible. This is due to prevent duplicated results - user may have the same username and real name.. and search looks for "contain" so the same user will be display twice. Also if real names are displayed, then username is hidden - thus you can't search it.

You may try 3rd party extensions if they allow you to what you need: extensions.joomla.org/extension/xius-for-jomsocial/

10. This activities seems to be empty. I need access to your site database via PHPmyAdmin to investigate their source. After taking a look into your site database I could say a bit more. Please, edit your first post and provide PHPmyAdmin credentials. or you may sent them to my email: This email address is being protected from spambots. You need JavaScript enabled to view it..


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
6 years 2 months ago
Licenses:
JomSocial Active

1) They told me to re-install Kunena so that I can have the Community plugin. There was no other way.
But Kunena Forum installation failed when it comes to installing Community plugin. But right now...the whole installation failed.

I don't know who's fault is it, but right now I don't have a Forum! And this is very very urgent for a site of my traffic. Until Kunena admins find out what is going on, is there a workaround here? Because all Kunena upgrades were always working normally with older JomSocial versions.

I need urgent help.

Attachments:
6 years 2 months ago
Licenses:
JomSocial Active

1)Ok for some weird reason, I fixed it.
I had to rename the folder /plugins/kunena/community to /community2

Then the installation was completed. Kunena - JomSocial Integration and the avatars work fine now.


2)Please take my opinion very seriously for this!
2 years ago I asked in this Forum that you implement an Advanced Search for both Full names and Usernames.
The reason: This is not Facebook. In a website, editors are well-known from their Full names. For example users search our profiles by typing our full name when they see it in an article or video (ex. Peter Smith).
But when users want to add each other in a social network, they add each other by using usernames (ex. "Hey add me in Jomsocial.com. My nickname is Devastator").

So basically by restricting the search field to only one option, you disallow users from using one feature or the other which is really bad! That's the most important thing that I had asked 2 years ago, maybe more, and I don't remember if JoomlArt had JomSocial. But this is a must feature and my point had taken many upvotes back then. This should be definitely added in this version. One of the reasons that I upgraded was this! At list since one of your developer promised it, I need a workaround! And it won't be that difficult. It's one of the most requested features from our users!

Otherwise, Iam really trying hard to understand the practical point of upgraded from v3 to v4. Maybe a better security? But with the speed being way slower and features like this being promised and not implemented (plus messages not having titles) there are real issues here that you must take care of asap.

6 years 2 months ago
Licenses:

HI, Manos.

1. That means that you had plugin files in your file system, but it was removed from Joomla! You may remove folder community2
So you can see that this issue was completely not related with JomSocial :)

2. I've tried to explain this in my previous post. You may choose to use usernames or real names. IN each case if you search for a profile, invite someone to be your friend or send an invitation - current setting is used.

So your site is set to display REAL NAMES now. So everywhere in your Community a real name is displayed. It's used in messages, invitations and so on. There is no place where username/login is displayed used.

Take a look here: prntscr.com/hlup29 I just sent an invitation to a friend. Note what name is used: "Michal JomSocial Support" that's a real name, while username/login is "Jomsocial".

So really I don't see any reason to be able to search by user name while it's nowhere used.

As for slow site - well, I do not experience that on your site. Upgrade it to 4.5 and try to use other browser. There was known bug in Chrome 62 that cause JS loading very slow. www.jomsocial.com/forum/installation/377...e-62?start=14#183366


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
6 years 2 months ago
Licenses:
JomSocial Active

Urgent: After I upgraded to JomSocial latest version, users can't register for a new account!

What's even worse to happen next?

Login and fix it asap!

Attachments:
6 years 2 months ago
Licenses:

Hi, Manos.

I'm sorry but your issue is not related with JomSocial in any way.
JomSocial registration form is here: www.gameworld.gr/community/register
I just registered without any issue: prntscr.com/hne0yt (user: michal jomsocial).
On your printscreen is... default JOOMLA! registration form.
And error is related with your Joomla! email SMTP settings as they can't be authenticated.
I'm sorry but I can't help you with that issue - JomSocial registration works properly.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW