Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated

Warning: sprintf(): Too few argument

1 year 9 months ago
Licenses:
JomSocial Active

Following the conversation on this thread: www.jomsocial.com/forum/photos-videos/35...-photo-page?start=14

Need help on this, language produces this error. The current language is es-ES.

Please notice I completed my registration on Transifex, requested access to the jomsocial translation project and was rejected (Without a reason).

Attachments:
1 year 9 months ago
Licenses:

HI, Luis.

Thank you for contacting us.
We do not provide reason for rejecting users in Transifex. We just can't disable it. Our policy is to have ONE translator per language and Spanish Translator is already present. You don't need to be Transifex member to download language pack as they are available here: www.jomsocial.com/translations

I see that Spanish translation stuck somewhere... I'll ask Translator if he's still with us. If not - are you interested to join translation project in exchange of free license? :)

In Jan's case it was much easier to locate which language string has fault. In your case is much harder as there are many on that page.

What you can do:

- disable error reporting and just hide that warning. it's not an error, but just warning. It won't influence your system performance in any way.
Browse to Backend -> System -> Global configuration -> Server -> Error displaying -> Default or NONE

- check if translation available on translation page do not have this issue.

- compare English and Spanish language files and locate where fault is. Probably somewhere too many placeholders are used. Just like in Jan's case.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
1 year 9 months ago
Licenses:
JomSocial Active

Thank you Michał. I understand that you do not give an explanation, that is clear. But in some instances on this forum some of the moderators have recomended "go to transifex and participate" and that is what I did.

Even when the exchange policy sounds great, I don´t see myself alone translating the whole thing. That should be a team work not only because of the extension but because it means changing the language but respecting the spirit of the most important community software on the web. I have a great deal of respect for jomsocial, have been around here since it looked like something made on an Atari computer. So if I can be part of a team, i´ll be on it.

Finaly, I have done your recomendations already, that´s why i´m here. Debug is set to NONE and it still showing that warning on the frontpage. Have been comparing the english and spanish file for some time. Maybe on of this days I´ll find this bug but that´s a lot of lines there.

Thank you for your help, i´ll notify here if I find a solution. Thanks.

1 year 9 months ago
Licenses:

HI, Luis.

We have rather different experience - in past there was many users that applied to the project... but most of them just wanted to download files. Also they often just abandon the project or edit what was already translated only to fit their needs. We decided to have one translator that is responsible for whole thing. Having one person to work with we could also reward his/hers efforts.

As for you issue - if setting to NONE do not hide the warning, it means your server is not configured properly as it should follow Joomla! settings.
error_reportings should be set to none.

prntscr.com/hjb2ci
prntscr.com/hjb35h

Further readings: www.ostraining.com/blog/joomla/warnings/


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW