Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Notifications module does not display SVG icons in Firefox with <base> set

2 years 3 weeks ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Dear JomSocial team,

we are having trouble with the Notifications module which does not show the SVG icons in Firefox when the <base> tag is set in the header. Please read the following for further information on the issue detailing what Firefox interprets differently: www.chriskrycho.com/2015/html5-location-base-and-svg.html

Could you please fix this bug in connection with Firefox and the use of <base> by including the SVG path in mod_community_notifications/tmpl/default.php at the place where the icon is displayed instead of referencing it.

Thank you and best regards

2 years 3 weeks ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

I need your backend access for testing this, because it can be caused by your Joomla template. Since this is working fine on my local code.

thank you

2 years 3 weeks ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

I have created a short mockup for you to be viewed in Firefox:



Best regards,

2 years 3 weeks ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

Well, I need check your backend site directly.. because I am not sure your html markup is different or not, since on our local there is no issue on it..



thank you

Attachments:
2 years 3 weeks ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

thank you for your continued support. I am not quite sure what you need to look at in our backend, since I used code from the latest JomSocial release to generate the mockup and have an external source verifying the issue.

If you add <base href="localhost/jomsocial">; to the head of your local installation's template a similar behavior should be visible in Firefox.

Best regards

2 years 2 weeks ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

I just wanna to make some test by using another Joomla template and another module position, so thats why I need your backend access.

If you wanna fix it by yourself you can modify this file modules/mod_community_notifications/tmpl/default.php, and edit the svg code like you did here jsfiddle.net/4f0pr3m9/4/

thank you!

2 years 2 weeks ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

Thank you for the support. I know what the issue is and how to fix it for us, but I believe this is a bug that can affect others as well and was hoping for an update of the module as it is delivered by you.

Best regards

2 years 2 weeks ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

If this issue still happens on next release (version 4.3) please let us know again, because on latest code (v4.3 internal beta) we dont see this issue :)

thank you!

2 years 4 days ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

Since the only change in this module between 4.2.5 and 4.3 Beta 1 is the incrementation of the version in the XML file, the bug still has not been solved.

Best regards

2 years 2 days ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

Please you wait version 4.2.6, we will released it very soon.. under testing now..

thank you

1 year 11 months ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

Since - again (!) - nothing has changed between 4.2.5, 4.2.6 and 4.3 Beta 2, the result is still the same and the bug remains.

I have provided you the details of the bug, the background as well as a solution, please let me know when this will be looked into and implemented.

Best regards

1 year 11 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

Ehm, weird.. I need to discuss this with our javascript developer, but right now he is off until next week.. he will marry next 2 days.. :D

So, please you wait next week then.

thank you

1 year 11 months ago
  • Peter's Avatar
    Topic Author
  • Peter
  • Offline
  • Fresh Boarder
  • Posts: 18
  • Thank you received: 1
Licenses:
JomSocial Active

Hi Dimas,

I do not really see how the JavaScript developer is required as there is no JavaScript involved in displaying the SVG icon... Is there someone for HTML topics - I believe that would be the better fit.

Best regards

1 year 11 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Peter,

our javascript developer is our frontend developer, which he is handle the HTML as well...

wait, i will ask another developer.

thank you!

Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW