Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Problem with Video search links

1 year 8 months ago
  • James's Avatar
    Topic Author
  • James
  • Offline
  • Fresh Boarder
  • Posts: 34
  • Thank you received: 0
Licenses:
JomSocial Active Socialize Active

I've noticed a problem with video search links on my site since updating Joomla, JomSocial and Socialize Templates. I'm not sure which update caused the change.

I have an old pre-update back-up of my site on my local machine and the video search links work fine.

It seams that the “View all videos” link in my “JS Videos Module” is incorrect after the update,
It used to be
www.harmonicaclub.com/my-membership/my-video-uploads/display
and now it is
www.harmonicaclub.com/my-membership/my-video-uploads
You can see my JS Videos module near the top left of my home page www.harmonicaclub.com

After updating my site I put a new drop-down in the Main Menu titled “Members Videos” and added links for all the search categories, and that works good because I used specific URL links for each category



If I go to Member's Videos>Chromatic>Blues the link brings you to
www.harmonicaclub.com/harmonica-videos?catid=15
However if you then use the drop-down menu (within the page) to go to All Categories>Chromatic>Blues

it brings you to
www.harmonicaclub.com/my-membership/my-video-uploads?catid=15
which displays search results for the member who is logged in, and not search results for all videos.

This problem is causing me a lot of anxiety,

Attachments:
1 year 8 months ago
Licenses:

HI, James.

Thank you for contacting us.
That issue is not caused by upgrade but by menu misconfiguration.
If you disable Joomla! SEF (what I did on your site), you'll notice that any URL references to videos and with 168 menu item ID:

www.harmonicaclub.com/index.php?option=c...ew=videos&Itemid=168

That menu item ID corresponds to your My Video Uploads menu item which displays current user videos. This menu item ID is used as "parent" ID for any links that refer to videos. So when SEF is enabled, Joomla! tries to load currently logged in user videos.

You need to either remove that item or change it to link to all videos. Then move it to hidden menu - any other menu that is not published on your site. And the create new menu item My Video Uploads that will lead to current user videos.

Joomla! will use lower menu item ID for all videos while current user videos page will have different menu item ID.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
1 year 8 months ago
  • James's Avatar
    Topic Author
  • James
  • Offline
  • Fresh Boarder
  • Posts: 34
  • Thank you received: 0
Licenses:
JomSocial Active Socialize Active

I'm finding this very difficult Michal, Can you post a link where I can read up and understand menus and SEF

1 year 8 months ago
Licenses:

HI, James.

There is no specific documentation for this as this is how Joomla! works with JomSocial.
Try to do as I said - if you can't manage it, I'll help you to change menu.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
The following user(s) said Thank You: James
1 year 8 months ago
  • James's Avatar
    Topic Author
  • James
  • Offline
  • Fresh Boarder
  • Posts: 34
  • Thank you received: 0
Licenses:
JomSocial Active Socialize Active

Thanks Michal,
I will come back to this problem. My members are pressing me to do other work on the site first, The main menu is working at the moment and the majority of my members don't notice this issue with the in-page drop menus. Thanks again for explaining the problem. I am not as worried as I was when I discovered it.

Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW