Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

after upgrade - pb cronjob and geocode

3 years 4 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

Hi,
after upgrading (which went fine), I got the following problems:
- the cron job doesn't work any more. The setcron jobs service receives the following error message "S3::getObject(, ): [InvalidAccessKeyId] The AWS Access Key Id you provided does not exist in our records". I don't have (and didn't have) any S3 service configured.
- for info when I get into the JomSocial component in the admin backend, there is an error message "Geocode was not successful for the following reason: ZERO_RESULTS"

BROWSER
safari

3 years 4 months ago
Licenses:

Hi.

I assign developer to this thread.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
3 years 4 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi,

This issue is valid bug and already assigned to the developer.

thank you!

3 years 3 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi,

To fix geo alert please you open this file administrator/components/com_community/views/community/tmpl/default.php
find this code :

alert('Geocode was not successful for the following reason: ' + status);
replace to :
console.log('Geocode was not successful for the following reason: ' + status);

thank you

3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

done.
the message disappeared.
Thanks
:-)

3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

Hi,
It was done for the problem on the message. But the problem with the cron job is still not resolved.
So I think that the ticket should not be tagged as "resolved" yet.
:-)

3 years 3 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Oh ya i forgot the another issue, anyway this issue seems caused by conflict with JSPT configuration.. can you check it with them as well, please?

3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

Hi Dimas,
it took some times, but we did some further test with JSPT team. Here below is there answer. It doesn't appear to be a problem with JSPT. Can you please explore further?

Actually unhooking JSPT means disabling the component as well its plugins. In short, its like uninstalling component from your end.

We did this to check whether this issue is caused by JSPT or not. But, as you can see, the error didn't go away even when JSPT was unhooked. So, I think JSPT is not the root cause of this issue.

In fact, I would suggest you to once uninstall XIPT and its two plugins JSPT Community Plugin as well as JSPT System Plugin completely. Then, try to run the cron. You'll notice that this error is not resolved that concludes that its not because of JSPT configuration.

For now, I have hooked JSPT back in your system.


Thanks
yves

3 years 3 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Dear Yves,

Please you try with the latest version 4.2.2, I hope it will be fine there.. let me know if this issue still persist

thank you

3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

HI,

same problem.

thanks

3 years 3 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Your amazon S3 configuration is empty, can you check it? please put the correct key




thank you!

Attachments:
3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

I don't have any amazon configuration and never had!

3 years 3 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Something wrong, some of code detect you set the amazon S3.. but this is not from our configuration... but well I already fix this by hack the code, I disabled any amazon storage transfer on cron job

3 years 3 months ago
  • yves's Avatar
    Topic Author
  • yves
  • Offline
  • Junior Boarder
  • Posts: 111
  • Thank you received: 5
Licenses:
JomSocial Active

Thanks, now the cronjob is working.
1°) any idea where this call to amazon could come from?
2°) as it is a hack you did, should I apply it again on the next update of JS? if yes, can you let me know where/what?

Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW