Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated

Lesson number reference above progress bar not correct.

7 years 6 months ago
Licenses:
JomSocial Expired GURU Expired

Michal, per your suggestion i have upgraded to latest Guru Pro, the numbering issue still persists.
for your reference, this course has 7 modules with 3 lessons each and a quiz. so i believe the indicator should show" Module 1/7, Lesson 1/21" then lesson 2/21 or is the lesson indicator intended to show the lesson total for the module?

I included the PHPmyAdmin login below

thanks in advance
Bill

ISSUE SUMMARY:
Good day,
I have a course with 7 modules, each module has minimum 3 lessons. All seems to be in order except the "module - course" reference located above the progress bar. The module count, 1/7 is correct but the lesson count and sequence are random and never correct after the initial lesson. example: first module and first lesson; "Module 1/7,Lesson 1/13" which is correct. progress to the next lesson and it reads; "Module 1/7, Lesson 8/13" ??? it should read; "Module 1/7, Lesson 2/13". Also the number of lessons is incorrect. when moving to module 2 lesson 2 the indicator reads Module 2/7, Lesson 2/5 See Screen shot
NOTE: the lessons themselves are displayed in proper sequence and order, it is only this indicator having the issue I believe.
I have included the course/lesson tree for reference.

Second - How to display the Module title or name in the course/lessons. For example when progressing from module 1 to module 2, the screen says in bold (Heading 1 I assume) "Module 2:" the title which follows Module 2: is omitted here. then the entire title is displayed again below. FYI if the progress bar is disabled the module numbering stays on 0 See screen shot

Third - I create text media for each lesson, some include bullet points, they display correctly in the text editor on the back-end but disappear on the front end? I have tested all optional bullet symbols and found that the numbering works but all others disappear.

I assume the problem is on my end for which i am sorry and sorry for my inept descriptions.
thanks very much in advance!
Bill

STEPS TO REPLICATE:
1 pmelearning.com > Register; UID "IJsupport", password "IJsupport"
2 >Lesson Center > My Courses > Project Time Management
3 > Module 1 > Lesson 1.1
4 Notice the "Module 1/7, Lesson 1/13" identifiers above the progress bar
5 click the progress forward link to progress to the next lesson and it reads; "Module 1/7, Lesson 8/13"
RESULT
it reads; "Module 1/7, Lesson 8/13"
EXPECTED RESULT
should read "Module 1/7, Lesson 2/13
BROWSER
Chrome, firefox, IE11

Attachments:
7 years 6 months ago
Licenses:

Hi, William.

First, please, upgrade to latest version of Guru -> 4.0.5 and check if issue persist.
If it still persist, please, edit your first post and add PHPmyAdmin credentials.
Then update this thread by posting it's done.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
The following user(s) said Thank You: William
7 years 6 months ago
Licenses:
JomSocial Expired GURU Expired

Hi Michal, thanks for the reply.
just to bring you up to speed,
My interest and the procduct we need up and running isGuru Pro.
I purchased Guru Pro and JomSocial as a package offered on the guru.ijoomla.com website thinking JomSocial might be a good idea for the future and the wording on the site indicates that functionality is missing from Guru Pro if the package is not purchased but didn't imagine that i would NOT have access to iJoomla Guro Pro support or the numerous issues listed below.
For some reason, i do NOT have access or VIP support via iJoomla?
iJoomla does NOT recognize that i have purchased Guru Pro. It only recognizes the trial of Guru Lite i did try initially.
Jomsocial DOES recognize that i have purchased both GURU Pro and Jomsocial.
Until yesterday, following a couple of forum messages sent to Pre-sales, i did NOT have access to post on JomSocial> Guru Pro forum and still do NOT on iJoomla Guru Pro VIP support.
The ijoomla-installer-updater which came in the download package when i purchased the software, throws an error that the license for both GURU Pro and JomSocial are incorrect, they are as they were sent to me and the products function as licensed products on the site.
the bottom line is > the updater does NOT work, "error the license is incorrect" If i click the link to upgrade on the top bar of the Guru Componet, it goes to iJoomla and says i only have GURU light and offers to upgrade to GURU Pro.

Now for your message:
I will be happy to upgrade if I only could! Is there a procedure to do so without the above described issues?

thanks in advance!
Bill

7 years 6 months ago
Licenses:

Hi, William.

Products purchased on jomsocial.com are supported on jomsocial.com as their license is attached here.
Thus you don't have access to iJoomla Guru support forum.
You should post your Guru related issues here.

Regarding iJoomla Installer and issue with Guru license purchase in bundle - I need to talk with our developers. I'll update you ASAP about this.

You may upgrade Guru manually by downloading latest version here:
www.jomsocial.com/component/digistore/licenses

And then install it on top of older version just like any other Joomla! extension.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
7 years 6 months ago
Licenses:

Hi, William.

Please, make sure you're using LATEST version of iJoomla Installer.
Download JomSocial package from here:
www.jomsocial.com/component/digistore/licenses

Unzip it and install iJoomla Installer on top of your current version.

For your convenience we will match your account on iJoomla so you could post there. It will be active within 24-48hrs.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
The following user(s) said Thank You: William
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW