Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Limit number of characters or words in Activity Stream module

4 years 6 months ago
  • Pablo's Avatar
    Topic Author
  • Pablo
  • Visitor
  • Thank you received: 0
Licenses:

Hello,

I have on my home page the Activity Stream module. The problem I have is that in many cases, like Kunena posts, it shows the whole post and at the end adds the "read more" link. I need to be able to limit the number of characters or word and then add the read more.

Could anyone be so kind as to help me with this?

Thanx!!

4 years 6 months ago
Licenses:

Hi, Pablo.

Where I could see that issue on your site?


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
4 years 6 months ago
  • Pablo's Avatar
    Topic Author
  • Pablo
  • Visitor
  • Thank you received: 0
Licenses:

Home page, activity stream, and also in tab "comunidad"

4 years 6 months ago
Licenses:

Hi, Pablo.

Those posts come straight from Kunena.
Please, post on Kunena forum and ask how to modify that.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
4 years 6 months ago
  • Pablo's Avatar
    Topic Author
  • Pablo
  • Visitor
  • Thank you received: 0
Licenses:

thanx!

4 years 2 months ago
  • Pablo's Avatar
    Topic Author
  • Pablo
  • Visitor
  • Thank you received: 0
Licenses:

Hello,

I am having the same problem with Facebook. Is there any way to limit the lenght of the text?

check it here, for example www.awesomescreenshot.com/image/376491/8...b43e5f89dbce26bea194

The main problem is in the Activity Stream, cause I have it in the home page and breaks the order of the mods.
thanks!

4 years 2 months ago
Licenses:

Hi, Pablo.

The only way to limit number of text in post is... to upgrade to JomSocial 4.0.8 as this feature is available there :)
Please, check our demo.jomsocial.com to see it in action ;)


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
1 year 6 months ago
Licenses:
JomSocial Active

And how to limit the kunnena words number for activity stream posts in Jomsocial 4.5? I have the same problem.

1 year 6 months ago
Licenses:
JomSocial Active GURU Active Publisher Active AdAgency Active iSEO Active Socialize Active

Hi

It's rather strange, but looks like this option has been removed from configuration. The only way to do it is to manually change the plugin /plugins/kunena/community/activity.php line 269:

$content = KunenaHtmlParser::parseBBCode($message->message, $parent, $this->params->get('activity_stream_limit', 0));

where the 0 is a number of letters being used in Jomsocial stream.

The following user(s) said Thank You: Beniamin
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW