Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Frontpage guest.php customisation

3 years 1 month ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

We have requested this fix before and Michal provided a suitable answer for JS v3, HERE , however this no longer applies to the newer version 4 jomSocial, as you have renamed and rewritten the code for these pages.

frontpage.guest.php has now become just guest.php and the code has been updated so the customisation mentioned above no longer applies and we have lost our customised front page.

Please revise the fix for JS v4 ASAP

3 years 1 month ago
Licenses:

Hi, Zurkster.

I'll add this request to my TODO list. But please, be aware that as JomSocial 4 is newly released, customizations request have lowest priority. So it make take some time when I'll be able to get back to i...


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
3 years 1 month ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

I have the same issue with the customised avatar sizes, they have all blown out of proportion too.

3 years 1 month ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

PS Michal, what sort of time scale are we talking about, as these errors are on a live site.

3 years 1 month ago
Licenses:

HI, Zurkster.

I can't say... it depends how crowded forum will be.
Please, note that these are not "errors" but your customization requests... and any customizations we provide are just a courtesy as customizations are not officially supported (please, read our Support Policy: www.jomsocial.com/support )


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
3 years 1 month ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

So how much to reproduce this Fix for JS v4.x if we're prepared to pay?
This offer extends to the continued development of the Kunena/JomSocial plugin which JomSocial have the source code for....
Many users would benefit from this plugin becoming available and stable with JS v4.

3 years 1 month ago
Licenses:

Hi, Zurkster.

We're not allowed to accept paid customizations... I'll provide code snippet for free but after it become more quite on forum.
I ask your patience...
As for Kunena Plugin, this will be improved - our developers work on this already.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 11 months ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

Hi again Michal, I asked a considerable while ago if you could look into providing a revised fix for the customised frontpage module inclusion to replace the default hero image. I have all the modules made up and were active until JomSocial v4 came about, now there have been a number of JomSocial revisions, but still no resolution to a feature we had come to depend on.

Thanks in advance for any help you can provide. This is an important landing page feature that without, is seriously affecting our new registrations.

2 years 11 months ago
Licenses:

Hi, Zurkster.

This fix will be not needed, as in JomSocial 4 this is much much easier.
All you need is to browse here:

Backend -> Components -> JomSocial -> Theme designer -> General -> Show frontpage image -> NO.

Then copy this file:

ROOT/components/com_community/templates/jomsocial/layouts/frontpage/guest.php

to:

ROOT/templates/your-template/html/com_community/layouts/frontpage (if you don't have any of those folders, feel free to create them)

Then add this code right above line 13:

<?php $this->renderModules('my_frontpage_module'); ?>

So now you should have your module position and be able to assign any module here, text "Get connected! with some additional lines (you may remove then by setting Show frontpage paragraph -> NO) and horizontal login form.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 11 months ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

So I have done as you suggested, however I am a little confused as to where exactly you want the snippet entered.
I entered the below code:

<?php $this->renderModules('my_frontpage_module'); ?>

directly before line 13 as you suggested, however your information is not accurate to the line count on my editor.

But as you can see the code lines before line 13 are in the titles.
* @copyright (C) 2013 iJoomla, Inc. - All rights reserved.

* @license GNU General Public License, version 2 (http://www.gnu.org/licenses/gpl-2.0.html)

* @author iJoomla.com <[email protected]>

* @url https://www.jomsocial.com/license-agreement
 ******  Line 13 is here on my editor *****
* The PHP code portions are distributed under the GPL license. If not otherwise stated, all images, manuals, cascading style sheets, and included JavaScript *are NOT GPL, and are released under the IJOOMLA Proprietary Use License v1.0

* More info at https://www.jomsocial.com/license-agreement

*/

defined('_JEXEC') or die();

?>



<div class="joms-landing <?php if (!$settings['general']['enable-frontpage-image']) echo "no-image"; ?>">

    <div class="joms-landing__cover">

        <?php if (isset($settings) && $settings['general']['enable-frontpage-image']) { ?>

            <div class="joms-landing__image" style="background:url(<?php echo $heroImage; ?>) no-repeat center center;">

            </div>

        <?php } ?>

        <div class="joms-landing__content">

            <div class="joms-landing__text">

                <h2><?php echo JText::_('COM_COMMUNITY_GET_CONNECTED_TITLE'); ?></h2>

                <?php if (isset($settings) && $settings['general']['enable-frontpage-paragraph']) { ?>

                    <p><?php echo JText::_('COM_COMMUNITY_HERO_PARAGRAPH'); ?></p>

                <?php } ?>

            </div>

Perhaps (as before) you could either demonstrate where exactly you suggest the code should be entered, perhaps by offering an example similar to the above, or more simply provide the amended guest.php file as an attachment. Please remember that I and many readers have support accounts here because we (unlike you) Michal are not professional coders. So please for the benefit of us less skilled developers. Throw us a bone! LOL

2 years 11 months ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

PS What is the position name for the modules? is it my_frontpage_module

2 years 11 months ago
Licenses:

Hi, Zurkster.

What editor do you use? :) I recommend BlueFish ;)

Paste code right before:

<div class="joms-landing <?php if (!$settings) echo "no-image"; ?>">

Yes, position name will be "my_frontpage_module". but you may change to whatever you like - just remember to NOT use spaces and non-Latin characters.

I'm sorry sometimes I forget about non-coders :) I explained it so many times on this forum... so I myself feel lost sometimes ;)

Please, let me know if something needs to be cleared more...


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 11 months ago
  • Zurkster's Avatar
    Topic Author
  • Zurkster
  • Visitor
  • Thank you received: 0
Licenses:

Just re-checked, that's how I assumed it should have been placed however, when I allocate a module to the defined position, still nothing displays on the page above the stream.

2 years 11 months ago
Licenses:

Hi, Zurkster.

Instructions are 100% correct. I' did a test here: www.prolusatia.nazwa.pl/test/
"Lorem ipsum" is a text in html module assigned to my_frontpage_module.

Credentials to your site doesn't work so I can't check your code.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW