Notice

The forum is in read only mode.

Support Forum

Welcome! Support Forums have been reactivated
Welcome the Technical Support section. Help us in assisting you by providing us with a concise and descriptive elaboration of your issues. Be specific and if possible, provide us with a step-by-step instruction in replicating your problem.

Edit photos and videos in groups

2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Hello,
Shouldn't it be possible for a user to edit his own photos and videos in posts made in groups?
I'm using version 4.6.2.
Thanks!

2 years 2 months ago
Licenses:

Hi, Lisa.

Thank you for contacting us.
Please, could you elaborate about this issue?
I just tested this on my dev site and as a regular user I was able to edit video or photo description.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

If I post a text message, I get the edit-option in the drop-down menu.
If I post a photo, I get the delete-option in the same drop-down menu.
I can click on the photo to edit the photo-description, but this doesn't show in the stream, there is the same text I posted with the photo.
Is this supposed to be so - or can it be changed?

2 years 2 months ago
Licenses:

HI, Lisa.

Okay, this may be a bit confusing but photo posted on stream has: comment and description.

You add your "comment", what is actually a initial message posted along with photo.
It's visible on stream above photo.
it's NOT visible when viewing photo in modal window.
You may edit it while clicking on caret icon and choosing "edit post". It changes.
prntscr.com/fhqt84

Photo description is visible when viewing photo in modal window.
It's NOT visible on stream.
You may add or edit it in modal window only.
prntscr.com/fhqtoo


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Ok then, the image description that is edited, is it not supposed to show on stream above the photo after it has been updated?

2 years 2 months ago
Licenses:

Hi, LIsa.

No, as description is NOT visible on the stream.
You can see it only when viewing photo in modal window.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Hi again :)

I know that the photo description doesn't show in the stream.
What I mean is that the comment above the photo - the actual post - can't be edited, but only deleted or hidden (slet and skjul in Danish)
On the JS Demo, there is the option of editing the post (see attachments)
So my question is: How can I get the edit-option like in the Demo?

Attachments:
2 years 2 months ago
Licenses:

Hi, LIsa.

I just tested this on my dev site and it works as it should. Are you sure that you're trying to edit that post as a original author (MARIA JENSEN)?


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Yes the person trying to edit, was the same person who wrote the post.
Even if I as a Super Admin make a post including a photo, the the "Edit Post" option doesn't appear. Only the delete-option, hide from wall and feature.
If I post a message including only text, the edit-option appears.
Any suggestions for this problem, please?

2 years 2 months ago
  • Dimas's Avatar
  • Dimas
  • Visitor
  • Thank you received: 0
Licenses:

Hi Lisa,

Here is the solution
- download this file www.dropbox.com/s/g8n8muhuxq3sy9v/photos.php?dl=0 and copy to this folder components/com_community/controllers/
- and download this file www.dropbox.com/s/m2eydqaiknxu6er/single.php?dl=0 copy to this folder components/com_community/templates/jomsocial/layouts/photos/

I hope it will fix the issue :)

2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Sorry, but then I get error message when I click on photo and there still isn't the edit-option in the drop-down menu. So I changed it back to the original files.

Attachments:
2 years 2 months ago
Licenses:

HI, Lisa.

In other post you mentioned that you're using JomSocial 4.2.6... is that correct? Could you upgrade to latest version first?


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
2 years 2 months ago
  • Lisa's Avatar
    Topic Author
  • Lisa
  • Offline
  • Fresh Boarder
  • Posts: 24
  • Thank you received: 0
Licenses:
JomSocial Expired

Do you think this problem might be solved by upgrading?

2 years 2 months ago
Licenses:

Hi, Lisa.

I'm not 100% sure but I tested this on latest version of JomSocial and it works... you reported this for outdated version.
We need to make sure we use the same versions so we could investigate.


- Instead of saying: 'it's not working', explain the problem in detail.
- Screenshots with the URL visible in them and the problem marked are more than welcome.
- Tell us how to replicate the problem, we can't fix it if we can't find it.
- Make sure that your site/server meets JomSocial System Requirements
- Make sure to setup JomSocial Cron Job
- Always provide us with access details to the backend and ftp. We need it to debug problems.
- If you have a similar problem, but a solution you found isn't working, open a new thread instead of 'merging' with an existing one.

- Use the "Thank You" feature on any post that helped you
Moderators: Piotr Garasiński
Powered by Kunena Forum

Join 180,000 websites creating Amazing communities

JomSocial is the most complete, easy-to-use addon that turns Joomla CMS into a
full -fledged, social networking site

TRY NOW BUY NOW